Rival Recruit CA disruption of service
Incident Report for Rival HR
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 16:38 EST
Identified
We are currently investigating an interruption of service with our Recruit application in Canada.
Posted Nov 06, 2024 - 16:00 EST
This incident affected: Recruit (Recruiting UI, CX UI).