Recruit - CX Portal

Incident Report for Rival HR

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 17:56 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 20, 2026 - 17:02 EST

Investigating

Some users may be experiencing a performance issue with the Recruit CX Portal. We are currently working on isolating root cause and will follow up as we progress towards resolution.
Posted Jan 20, 2026 - 16:00 EST
This incident affected: Recruit (CX UI).