US Recruit and CX - investigating issues with application responsiveness

Incident Report for Rival HR

Resolved

This incident has been resolved.
Posted May 22, 2025 - 10:23 EDT

Investigating

We are currently investigating this issue.
Posted May 22, 2025 - 09:24 EDT
This incident affected: Recruit (Recruiting UI, CX UI, ePosting UI, iPostings UI).