E-Verify Services

Incident Report for Rival HR

Resolved

Posted Oct 09, 2025 - 10:50 EDT

Update

Please stop sending notifications, there's nothing we can do about it. It's not a problem on our end.
Posted Oct 07, 2025 - 15:25 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 07, 2025 - 10:00 EDT

Update

This is due to the gov't shutdown which includes USCIS. EVS will keep trying to contact USCIS until they come back on. We can otherwise ignore this message.
Posted Oct 07, 2025 - 10:00 EDT

Monitoring

Due to the government shutdown, E-Verify services are disabled with the Workflow application. Any case submissions are currently being queued up and will be processed once the service becomes available. Check E-Verify's official website (e-verify.gov) for the most current information and updates on when services will be restored. https://www.e-verify.gov
Posted Oct 06, 2025 - 14:52 EDT
This incident affected: Workflow (USCIS - eVerify).